Volkswagen Tiguan MK2 Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello,

New to the forum :)

So I have a MK 2 Tiguan 2017 diesel 35k an has thrown up a engine check light.

I had the code read and is showing as P154B , is anyone familiar with what might be the issue ?

Thanks Matt
 

·
Registered
Joined
·
1,212 Posts
Welcome to the Forum.
P154B relates to a faulty Diesel Particulate Filter (DPF) differential pressure sensor.
Should be covered by warranty.
 

·
Registered
Joined
·
1,212 Posts
I suspect the fault is related to a faulty pressure sensor- not a dirty DPF.
 

·
Registered
Joined
·
268 Posts
Just been to my local indie and coincidentally he has a Tiguan R Line in with a faulty DPF pressure sensor too!
 

·
Registered
Joined
·
21 Posts
Matthewuk said:
Hello,

New to the forum :)

So I have a MK 2 Tiguan 2017 diesel 35k an has thrown up a engine check light.

I had the code read and is showing as P154B , is anyone familiar with what might be the issue ?

Thanks Matt
Had the same problem with my 2017 , 19K miles. DPF sensor replaced under warranty :D
 

·
Registered
Joined
·
51 Posts
Same problem in my 2017, got the sensor from VW and replaced it myself. The sensor looks different to the one installed, I guess it's an upgraded version. A little bit tricky to remove the rubber hoses, but no other issues. So far so good.
Water Atmosphere Sky Moon Liquid


Interestingly, the car mileage is now 66500, so the error occurred around 2000km ago for the first time, which would be 2-3 months ago as I don't drive much, but the engine light just came on recently.

Old sensor (removed), new sensor installed.
Hood Bumper Motor vehicle Automotive design Automotive exterior
 

·
Registered
Joined
·
1 Posts
Same problem in my 2017, got the sensor from VW and replaced it myself. The sensor looks different to the one installed, I guess it's an upgraded version. A little bit tricky to remove the rubber hoses, but no other issues. So far so good.
View attachment 8682

Interestingly, the car mileage is now 66500, so the error occurred around 2000km ago for the first time, which would be 2-3 months ago as I don't drive much, but the engine light just came on recently.

Old sensor (removed), new sensor installed.
View attachment 8683
Hi,

did you have to do the adaptation after replacement and if yes, where did you do it - engine-coding2, basic settings, adaptations or ?
 

·
Registered
Joined
·
51 Posts
Hi,

did you have to do the adaptation after replacement and if yes, where did you do it - engine-coding2, basic settings, adaptations or ?
You don't have to do any adaptation, just swap the sensor. I don't even remember if I had to clear the check engine light or it went away on its own.
 

·
Registered
Joined
·
1 Posts
Same problem in my 2017, got the sensor from VW and replaced it myself. The sensor looks different to the one installed, I guess it's an upgraded version. A little bit tricky to remove the rubber hoses, but no other issues. So far so good.
View attachment 8682

Interestingly, the car mileage is now 66500, so the error occurred around 2000km ago for the first time, which would be 2-3 months ago as I don't drive much, but the engine light just came on recently.

Old sensor (removed), new sensor installed.
View attachment 8683
Thanks Kucyk. This post helps a lot, had the light come up yesterday (mileage 33k) and diagnostics revealed P145b error. Replacing the sensor on Friday which should resolve the issue.
 
1 - 10 of 10 Posts
Top